Downtime in US region

Incident Report for Pactum AI

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 12:43 UTC

Monitoring

Pactum US region was unavailable between 12:03 and 12:43 UTC due to an unexpected failure of a planned deployment. All services are restored to normal.
Posted Nov 28, 2025 - 12:03 UTC
This incident affected: Supplier Portal and Suite.